Windows XP Windows XP SP3 32bit en SP2 64bit certificate error (ERR_CERT_AUTHORITY_INVALID)

danny53

Bekend gezicht
Lid geworden
28 dec 2015
Berichten
108
Reaction score
6
Punten
18
Leeftijd
31
Windows XP SP3 32bit en SP2 64bit lijken sinds kort opnieuw te zijn overleden. (begin dit jaar of ergens vorig jaar werden websites nog probleemloos geladen op Chrome, en ook YouTube werkte daarop) Websites worden in geen enkele browser meer fatsoenlijk geladen, (ongeldige certificaat error, op alle browsers bij elke websites behalve op Firefox), YouTube blijft hangen op loader.
Op Firefox werkt YouTube wel zonder certificaat error, Uitzending gemist werkt op geen enkele browser meer, blijft hangen en error 22 op Firefox. (ook de NIET DRM streams worden niet meer afgespeeld)
Ja ik gebruik geen XP, maar vroeg mij af hoe het met XP staat.

Wat is eigenlijk die certificaat dinges? Is dat te omzeilen?
En waarom werkt het eigenlijk nog wel op Firefox?
Dat wou ik eigenlijk even weten.

Hopeloos dit voor de XP gebruikers. Benieuwd hoelang Firefox nog blijft werken.
Als ie er ook mee stopt, is het end of life van YouTube en Uitzending gemist op Windows XP.

chrome.jpgchrome2.PNGfirefox.PNGie.PNGie2.PNGopera.PNGopera2.PNGsafari.PNGvivaldi.PNGvivaldi2.PNG
 
Laatst bewerkt:

Black Tiger

Netwerk hobbyist. :)
Lid geworden
16 sep 2019
Berichten
185
Reaction score
34
Punten
28
Website
www.satellitefun.org
Wat is eigenlijk die certificaat dinges? Is dat te omzeilen?
En waarom werkt het eigenlijk nog wel op Firefox?
Ik heb dit ook al in Firefox gezien op een Windows 7 pc toevallig vanavond bij de buren. En nog wel bij toolslib.net waar ik met Windows 10 hier thuis geen problemen mee had.

Oke even kort uitleggen.
ERR_CERT_AUTHORITY_INVALID
betekent dat de certificaat authoriteit ongeldig is. Met het certificaat bedoelen ze het SSL certificaat wat je nodig hebt om https verbindingen te kunnen op zetten in dit geval.

Het probleem kan mogeljik liggen aan LetsEncrypt die gratis SSL certificaten verstrekt.
Door een op 29 februari geconstateerde bug in Letsencrypt is het nodig geworden dat ze per 4 maart enkele miljoenen certificaten ingetrokken moesten worden c.q. ongeldig verklaard.

De meeste mensen zijn van dit nieuws op de hoogte en hebben inmiddels voor een nieuw certificaat gezorgd. Maar er zijn nog vele sites die dat nog niet gedaan hebben.

Dat kan dus ook nog een oorzaak zijn.

Verder gaat inderdaad XP ondersteuning uitgeschakeld worden maar wie weet misschien ook al Windows 7. Heb dat verder niet getest overigens.

Andere optie kan ook nog malware zijn maar dat lijkt me in dit geval niet.
 

danny53

Bekend gezicht
Lid geworden
28 dec 2015
Berichten
108
Reaction score
6
Punten
18
Leeftijd
31

Black Tiger

Netwerk hobbyist. :)
Lid geworden
16 sep 2019
Berichten
185
Reaction score
34
Punten
28
Website
www.satellitefun.org
Netjes, dan lag het in jouw geval dus dat Windows Update er geen updates meer voor geeft en er wel een nodig was schijnbaar.
Mooi opgelost!
 

hermanmicra

Junior lid
Lid geworden
30 mrt 2008
Berichten
36
Reaction score
0
Punten
6
Als je met XP werkt heb je waarschijnlijk Firefox 52.9.0 ESR en die komt uit 2017 (dacht ik )
en is sterk verouderd en het zal steeds moeilijker worden om hier nog mee te surfen.
( sites openen niet meer of niet goed )
We zitten nu op FF 74.0

Ik heb nog heel lang gewerkt met 98SE met FF 20.020 (2015) maar het gaat gewoon niet meer
op het laatst.......er is voor xp niets meer te vinden ( browser en antivirus )
 

danny53

Bekend gezicht
Lid geworden
28 dec 2015
Berichten
108
Reaction score
6
Punten
18
Leeftijd
31
Netjes, dan lag het in jouw geval dus dat Windows Update er geen updates meer voor geeft en er wel een nodig was schijnbaar.
Mooi opgelost!
Ik heb nog steeds certificaat error, alleen niet meer op elke website. YouTube niet meer bijvoorbeeld.
 

Black Tiger

Netwerk hobbyist. :)
Lid geworden
16 sep 2019
Berichten
185
Reaction score
34
Punten
28
Website
www.satellitefun.org
Het zal steeds moeilijker worden. Want TLS 1.0 en 1.1 is al op veel websites uitgeschakeld en zal op nog meer sites uitgeschakeld worden. Werd ook tijd overigens.
Daarnaast gebeurt dit nu ook al bij heel veel hosting providers ook v.w.b. de e-mail. Apple, Gmail en Office365 volgen snel, in elk geval sowieso vanaf juni dit jaar.

Dus tls 1.2 support moet sowieso aan staan in de browsers. Standaard staat dit aan overigens.
Maar voor oudere Outlook versies en andere oudere mail programma's zal dat apart geactiveerd moeten worden.
Er zijn zelfs al Windows 7 gebruikers die hier last van hebben/krijgen.
 
Bovenaan Onderaan